Ignore:
Timestamp:
08/18/12 11:37:34 (9 years ago)
Author:
ehuelsmann
Message:

Move exports from autoloads.lisp to the respective defining files.
Also, delete JVM-COMPILE-PACKAGE, which hasn't been used in our
sources for ages and doesn't seem to serve an external purpose.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/abcl/src/org/armedbear/lisp/gui.lisp

    r12749 r14121  
    22
    33(require :java)
     4
     5(export '(*gui-backend* init-gui make-dialog-prompt-stream))
     6
    47
    58(defvar *gui-backend* :swing)
     
    1619(defmethod %make-dialog-prompt-stream ((gui-backend (eql :swing)))
    1720  (java:jnew (java:jconstructor
    18         "org.armedbear.lisp.java.swing.SwingDialogPromptStream")))
     21              "org.armedbear.lisp.java.swing.SwingDialogPromptStream")))
    1922
    2023(defmethod %make-dialog-prompt-stream ((gui-backend (eql :awt)))
    2124  (java:jnew (java:jconstructor
    22         "org.armedbear.lisp.java.awt.AwtDialogPromptStream")))
     25              "org.armedbear.lisp.java.awt.AwtDialogPromptStream")))
Note: See TracChangeset for help on using the changeset viewer.