Ignore:
Timestamp:
10/29/12 09:30:15 (8 years ago)
Author:
Mark Evenson
Message:

jna: Update to jna-3.5.1.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/abcl/contrib/mvn/jna.asd

    r14217 r14225  
    33;;;; Need to have jna.jar present for CFFI to have a chance of working.
    44(asdf:defsystem :jna
    5     :version "3.5.0"
     5    :version "3.5.1"
    66    :defsystem-depends-on (jss abcl-asdf)
    77;; FIXME: always seems to be resolving the LATEST maven artifact.
    8     :components ((:mvn "net.java.dev.jna/jna/3.5.0")))
     8    :components ((:mvn "net.java.dev.jna/jna/3.5.1")))
    99
    1010(in-package :asdf)
     
    2222    (java:java-exception (e)
    2323      (unless
    24           (java:add-to-classpath (abcl-asdf:resolve "net.java.dev.jna:jna:3.4.0"))
     24          (java:add-to-classpath (abcl-asdf:resolve "net.java.dev.jna:jna:3.5.1"))
    2525        (unless
    2626            ;; Might want to download to local filesystem, then place in classpath
    27             (java:add-to-classpath #p"http://repo1.maven.org/maven2/net/java/dev/jna/jna/3.5.0/jna-3.5.0.jar")
     27            (java:add-to-classpath #p"http://repo1.maven.org/maven2/net/java/dev/jna/jna/3.5.1/jna-3.5.1.jar")
    2828          (error "Failed to load jna-3.5.0.jar from the network via URI."))
    2929        (error "Failed to load jna.jar via ABCL-ASDF.")))
Note: See TracChangeset for help on using the changeset viewer.