Changeset 14261


Ignore:
Timestamp:
11/28/12 18:48:10 (8 years ago)
Author:
Mark Evenson
Message:

abcl-contrib> QUICKLISP-ABCL now installs Quicklisp from the REPL.

Use via

(dolist (system (:abcl-contrib :quicklisp-abcl)) (require system))

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/abcl/contrib/quicklisp/quicklisp-abcl.asd

    r14224 r14261  
    2020    (if (probe-file quicklisp-init)
    2121        (load quicklisp-init)
    22         (progn
    23           (load "http://beta.quicklisp.org/quicklisp.lisp")
    24           (funcall (intern "INSTALL" "QUICKLISP-QUICKSTART"))))))
     22        (handler-case
     23            (load "https://beta.quicklisp.org/quicklisp.lisp")
     24          (error (e)
     25            (warn "Using insecure transport for remote installation
     26              of Quicklisp:~&~A~&." e)
     27            (load "http://beta.quicklisp.org/quicklisp.lisp"))))
     28    (unless (find-package :quicklisp)
     29      (funcall (intern "INSTALL" "QUICKLISP-QUICKSTART")))))
     30
    2531       
    2632   
Note: See TracChangeset for help on using the changeset viewer.