Changeset 8293


Ignore:
Timestamp:
12/26/04 16:10:27 (17 years ago)
Author:
piso
Message:

Changed order of tests for Java version.

Location:
trunk/j
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/j/configure

    r7934 r8293  
    11#! /bin/sh
    2 # From configure.ac Revision: 1.66 .
     2# From configure.ac Revision: 1.67 .
    33# Guess values for system-dependent variables and create Makefiles.
    44# Generated by GNU Autoconf 2.59.
     
    14081408
    14091409case "$JAVA_VERSION" in
    1410     java*1.1*)
    1411         { { echo "$as_me:$LINENO: error: Java 1.4 or later is required" >&5
    1412 echo "$as_me: error: Java 1.4 or later is required" >&2;}
    1413    { (exit 1); exit 1; }; }
    1414         ;;
    1415     java*1.2.*)
    1416         { { echo "$as_me:$LINENO: error: Java 1.4 or later is required" >&5
    1417 echo "$as_me: error: Java 1.4 or later is required" >&2;}
    1418    { (exit 1); exit 1; }; }
    1419         ;;
    1420     java*1.3*)
    1421         { { echo "$as_me:$LINENO: error: Java 1.4 or later is required" >&5
    1422 echo "$as_me: error: Java 1.4 or later is required" >&2;}
    1423    { (exit 1); exit 1; }; }
     1410    java*1.5*)
     1411        echo "$as_me:$LINENO: result: $JAVA_VERSION" >&5
     1412echo "${ECHO_T}$JAVA_VERSION" >&6
    14241413        ;;
    14251414    java*1.4*)
     
    14271416echo "${ECHO_T}$JAVA_VERSION" >&6
    14281417        ;;
    1429     java*1.5*)
    1430         echo "$as_me:$LINENO: result: $JAVA_VERSION" >&5
    1431 echo "${ECHO_T}$JAVA_VERSION" >&6
    1432         ;;
    14331418    *)
    1434         { { echo "$as_me:$LINENO: error: unknown Java version" >&5
    1435 echo "$as_me: error: unknown Java version" >&2;}
     1419        { { echo "$as_me:$LINENO: error: Java 1.4 or later is required" >&5
     1420echo "$as_me: error: Java 1.4 or later is required" >&2;}
    14361421   { (exit 1); exit 1; }; }
    14371422        ;;
  • trunk/j/configure.ac

    r7933 r8293  
    22dnl
    33dnl  Copyright (C) 1998-2004 Peter Graves
    4 dnl  $Id: configure.ac,v 1.66 2004-10-09 00:02:02 piso Exp $
     4dnl  $Id: configure.ac,v 1.67 2004-12-26 16:09:52 piso Exp $
    55dnl
    66dnl  This program is free software; you can redistribute it and/or
     
    1818dnl  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
    1919
    20 AC_REVISION($Revision: 1.66 $)
     20AC_REVISION($Revision: 1.67 $)
    2121
    2222BOOTFILE=./configure-options
     
    9595
    9696case "$JAVA_VERSION" in
    97     java*1.1*)
    98         AC_MSG_ERROR(Java 1.4 or later is required)
    99         ;;
    100     java*1.2.*)
    101         AC_MSG_ERROR(Java 1.4 or later is required)
    102         ;;
    103     java*1.3*)
    104         AC_MSG_ERROR(Java 1.4 or later is required)
     97    java*1.5*)
     98        AC_MSG_RESULT($JAVA_VERSION)
    10599        ;;
    106100    java*1.4*)
    107101        AC_MSG_RESULT($JAVA_VERSION)
    108102        ;;
    109     java*1.5*)
    110         AC_MSG_RESULT($JAVA_VERSION)
    111         ;;
    112103    *)
    113         AC_MSG_ERROR(unknown Java version)
     104        AC_MSG_ERROR(Java 1.4 or later is required)
    114105        ;;
    115106esac
Note: See TracChangeset for help on using the changeset viewer.