Opened 13 years ago

Closed 12 years ago

Last modified 7 years ago

#11 closed enhancement (duplicate)

Integration of invoke.lisp, dynamic dispatch of java methods

Reported by: ehuelsmann Owned by: somebody
Priority: minor Milestone:
Component: other Version:
Keywords: Cc:
Parent Tickets:

Description

Just as the topic says, there's (rudimentary) support of dynamic dispatch elsewhere on the web in a file 'invoke.lisp'.

ABCL could greatly benefit by delivering this kind of behaviour by default.

Change History (3)

comment:1 Changed 13 years ago by Mark Evenson

This ticket references Alan Ruttenberg's [invoke.lisp][1], which uses the [JScheme implementation][2] to dynamically dispatch method calls. This entails having the 'jscheme.jar' in ABCL's invoked classpath. The property 'additional.jars' in the Ant based build system can be used to include such jars in the ABCL wrapper script.

[1]: http://svn.mumble.net:8080/svn/lsw/trunk/jss/invoke.lisp
[2]: http://jscheme.sourceforge.net/jscheme/main.html

comment:2 Changed 13 years ago by Mark Evenson

See ticket:18 for additional behavior from 'invoke.lisp' to incorporate here.

comment:3 Changed 12 years ago by Mark Evenson

Resolution: duplicate
Status: newclosed

duplicate of #18.

Last edited 7 years ago by Mark Evenson (previous) (diff)
Note: See TracTickets for help on using tickets.