Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#131 closed defect (fixed)

LISP-IMPLEMENTATION-VERSION with svn information breaks SLIME.

Reported by: Mark Evenson Owned by: Mark Evenson
Priority: minor Milestone: 0.27
Component: java Version:
Keywords: pathname Cc:
Parent Tickets:

Description

Reported by ehu via #abcl.

Change History (5)

comment:1 Changed 9 years ago by Mark Evenson

The problem is that the string returned by LISP-IMPLEMENTATION-VERSION is not a proper pathname component under Windows due to the ':' character.

  1. PATHNAME should reject this as a argument to its constructors.
  1. There should be a way to sanitize the output of LISP-IMPLEMENTATION-VERSION so that it is acceptable to PATHNAME. This relevant code should be added to SLIME.

comment:2 Changed 9 years ago by Mark Evenson

Component: CLOSjava
Keywords: pathname added
Milestone: 0.27
Priority: majorminor
Status: newassigned

comment:3 Changed 9 years ago by Mark Evenson

Resolution: fixed
Status: assignedclosed

comment:4 Changed 9 years ago by Mark Evenson

Fixed in r13438.

comment:5 Changed 9 years ago by Mark Evenson

Err, fixed in r13439.

Note: See TracTickets for help on using tickets.