Opened 9 years ago

Closed 9 years ago

#160 closed defect (fixed)

Printing objects with "#<" in their readable representation fail to print readably

Reported by: ehuelsmann Owned by: somebody
Priority: major Milestone: 0.27
Component: CLOS Version:
Keywords: Cc:
Parent Tickets:

Description

(let ((s (gensym "#<"))

(*print-readably* t))

(print s))

--> Error: Object cannot be printed readably

However, the readable presentation of that symbol is #:|#<1|.

Change History (4)

comment:1 Changed 9 years ago by ehuelsmann

(In [13409]) Re #160: note the root cause.

comment:2 Changed 9 years ago by ehuelsmann

The solution here is that each writeToString() method checks its own *print-readably* conditions. (Unfortunately, there are *lots* of those...)

comment:3 Changed 9 years ago by Mark Evenson

Milestone: 0.27

comment:4 Changed 9 years ago by ehuelsmann

Resolution: fixed
Status: newclosed

Fixed in r13446.

Note: See TracTickets for help on using tickets.