Opened 9 years ago

Closed 8 years ago

#174 closed defect (wontfix)

Conformance bug in time implementation when using SLIME

Reported by: Blackout Pro Owned by: Mark Evenson
Priority: minor Milestone: 1.1.0
Component: other Version: 0.27
Keywords: cl:time macro has-test slime Cc: stassats@…
Parent Tickets:

Description

ABCL's time implementation does not return multiple values as specified in HyperSpec?.

(time (values 1 2)) => 1 instead of 1 and 2

a test could be

(assert (= 2 (length (multiple-value-list (time (values 1 2))))))

an implementation is given here.

Change History (15)

comment:1 Changed 9 years ago by Blackout Pro

Milestone: unscheduled

comment:2 Changed 9 years ago by Mark Evenson

Keywords: ansi added; bug removed
Milestone: unscheduled1.0

comment:3 Changed 9 years ago by ehuelsmann

Hmm. no idea what's going on:

CL-USER(1): (time (values 1 2 3))
0.0 seconds real time
0 cons cells
1
2
3
CL-USER(2):

So, this works for me...

comment:4 Changed 9 years ago by Blackout Pro

I had a better look, it works via terminal but not via slime, my fault, sorry.

comment:5 Changed 9 years ago by Mark Evenson

Milestone: 1.01.0.1

comment:6 Changed 9 years ago by Mark Evenson

Keywords: ansi-conformance added; ansi conformance removed

comment:7 Changed 9 years ago by Mark Evenson

Milestone: 1.0.11.1.0

comment:8 Changed 9 years ago by Mark Evenson

Priority: trivialblocker

comment:9 Changed 9 years ago by Mark Evenson

Keywords: time, macro, ansi-conformancetime macro ansi-conformance

comment:10 Changed 8 years ago by Mark Evenson

Owner: changed from somebody to Mark Evenson
Status: newassigned

comment:11 Changed 8 years ago by Mark Evenson

Keywords: cl:time has-test added; time removed

comment:12 Changed 8 years ago by rschlatte

Summary: Conformance bug in time implementationConformance bug in time implementation when using SLIME

comment:13 Changed 8 years ago by ehuelsmann

Keywords: slime added; ansi-conformance removed
Priority: blockerminor

Not ansi-conformance nor blocker for 1.1.0.

Adding SLIME keyword because SLIME is definitely involved.

comment:14 Changed 8 years ago by stassats

Cc: stassats@… added

I cannot reproduce this in slime, and I see no possible reason why it could behave in such a way under slime.

comment:15 Changed 8 years ago by Evenson Not Org

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.