Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#211 closed defect (worksforme)

closure-common fails to load correctly after compilation

Reported by: Mark Evenson Owned by: Mark Evenson
Priority: minor Milestone: 1.1.0
Component: compiler Version: 1.1.0-dev
Keywords: clos compiler needs-test quicklisp closure-common Cc:
Parent Tickets:

Description

When compiling the fasl for closure-common/ystream.abcl an
error in StandardClass?.getClassLayout(StandardClass:205) in reading back the parameters.

Interestingly, if the system is restarted, the fasl *can* be loaded without complaint, so there seems to be some artifact of the compilation process "hanging around" in memory which causes this problem.

Unknown whether this affects the actual us of closure-common

This error existed in abcl-1.0.1 as well, so it has nothing to do with the recent work on the MOP.

0: (#<FUNCTION {50F2A460}> #<TYPE-ERROR {79D34CA}> #<FUNCTION {50F2A460}>)
  1: (APPLY #<FUNCTION {50F2A460}> (#<TYPE-ERROR {79D34CA}> #<FUNCTION {50F2A460}>))
  2: (SYSTEM::RUN-HOOK SYSTEM::*INVOKE-DEBUGGER-HOOK* #<TYPE-ERROR {79D34CA}> #<FUNCTION {50F2A460}>)
  3: (INVOKE-DEBUGGER #<TYPE-ERROR {79D34CA}>)
  4: org.armedbear.lisp.Lisp.error(Lisp.java:379)
  5: org.armedbear.lisp.Lisp.type_error(Lisp.java:420)
  6: org.armedbear.lisp.Cons.length(Cons.java:240)
  7: org.armedbear.lisp.Cons.copyToArray(Cons.java:352)
  8: org.armedbear.lisp.LispThread.pprint(LispThread.java:896)
  9: org.armedbear.lisp.LispThread.pprint(LispThread.java:916)
 10: org.armedbear.lisp.LispThread.pprint(LispThread.java:916)
 11: org.armedbear.lisp.LispThread.printBacktrace(LispThread.java:825)
 12: org.armedbear.lisp.LispThread.printBacktrace(LispThread.java:807)
 13: org.armedbear.lisp.StandardClass.getClassLayout(StandardClass.java:206)
 14: org.armedbear.lisp.Layout$6.execute(Layout.java:269)
 15: org.armedbear.lisp.Symbol.execute(Symbol.java:802)
 16: org.armedbear.lisp.LispThread.execute(LispThread.java:649)
 17: org.armedbear.lisp.clos_728.execute(clos.lisp:3470)
 18: org.armedbear.lisp.CompiledClosure.execute(CompiledClosure.java:185)
 19: org.armedbear.lisp.LispThread.execute(LispThread.java:760)
 20: org.armedbear.lisp.Lisp.funcall(Lisp.java:186)
 21: org.armedbear.lisp.Primitives$pf_apply.execute(Primitives.java:2817)
 22: (SYSTEM:%MAKE-INSTANCES-OBSOLETE #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}>)
 23: (#<FUNCTION {1455BCD7}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MIXIN {7203E3B5}> #<STANDARD-CLASS GRAY-S..
 24: (APPLY #<FUNCTION {1455BCD7}> (#<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MIXIN {7203E3B5}> #<STANDARD-CLASS..
 25: (#<STANDARD-GENERIC-FUNCTION REINITIALIZE-INSTANCE {665C1EAE}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MI..
 26: (APPLY #<STANDARD-GENERIC-FUNCTION REINITIALIZE-INSTANCE {665C1EAE}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STR..
 27: (#<FUNCTION {5FE63CB6}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> RUNES::OCTET-INPUT-STREAM :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MIXIN {7203E3B5..
 28: (APPLY #<FUNCTION {5FE63CB6}> (#<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> RUNES::OCTET-INPUT-STREAM :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MIXIN {7..
 29: (#<STANDARD-GENERIC-FUNCTION ENSURE-CLASS-USING-CLASS {1A3526CF}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> RUNES::OCTET-INPUT-STREAM :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-S..
 30: (APPLY #<STANDARD-GENERIC-FUNCTION ENSURE-CLASS-USING-CLASS {1A3526CF}> #<STANDARD-CLASS RUNES::OCTET-INPUT-STREAM {7F83698F}> RUNES::OCTET-INPUT-STREAM (:DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL..
 31: (SYSTEM:ENSURE-CLASS RUNES::OCTET-INPUT-STREAM :DIRECT-SUPERCLASSES (#<STANDARD-CLASS TRIVIAL-GRAY-STREAMS:TRIVIAL-GRAY-STREAM-MIXIN {7203E3B5}> #<STANDARD-CLASS GRAY-STREAMS:FUNDAMENTAL-BINARY-INPUT-..

Change History (4)

comment:1 Changed 8 years ago by ehuelsmann

Can't reproduce on current trunk.

Hope mevenson can, otherwise we should close as fixed.

comment:2 Changed 8 years ago by ehuelsmann

Owner: changed from ehuelsmann to Mark Evenson
Status: newassigned

Assigning to mevenson so it's clear that I'm waiting for his input on the reproduction.

comment:3 Changed 8 years ago by ehuelsmann

Resolution: worksforme
Status: assignedclosed

Works for both mevenson and me.

comment:4 Changed 8 years ago by Evenson Not Org

CXML loads but XPath *still* borks the compiler on a hairy fasl that we need to graph to debug.
@armedbear .

Note: See TracTickets for help on using tickets.