Opened 8 years ago

Closed 8 years ago

#246 closed defect (fixed)

CFFI: dynamically generated classes referred from .fasl can not be found after ABCL restart

Reported by: Anton Vodonosov Owned by: Mark Evenson
Priority: critical Milestone: 1.1.0
Component: libraries Version: 1.1.0-dev
Keywords: cffi Cc:
Parent Tickets:

Description

Armed Bear Common Lisp 1.1.0-dev-svn-14181
Java 1.6.0_24 Sun Microsystems Inc.

(java:add-to-classpath "my-jna/jna.jar")
(provide 'jna)
(ql:quickload :drakma) ;; depends on CL+SSL

Do it first time after removing ~/.cache/common-lisp/.
Works OK.

Restart ABCL. Try the same code:

Error loading C:/Users/anton/AppData/Local/common-lisp/cache/abcl-1.1.0-dev-svn-14181-fasl39-win-x86/C/Users/anton/quicklisp/dists/quicklisp/software/cl+ssl-20120703-git/ffi.abcl at line 168 (offset 9483)
#<THREAD "interpreter" {1A705D7}>: Debugger invoked on condition of type ERROR
  Class not found: org.armedbear.jna.dynamic.callbacks.G91513
Restarts:
  0: TRY-RECOMPILING Recompile ffi and try loading it again
  1: RETRY           Retry loading FASL for #<ASDF:CL-SOURCE-FILE "cl+ssl" "ffi">.
  2: ACCEPT          Continue, treating loading FASL for #<ASDF:CL-SOURCE-FILE "cl+ssl" "ffi"> as having been successful.
  3: ABORT           Give up on "drakma"
  4: TOP-LEVEL       Return to top level.
[1] CL+SSL(4):

Change History (4)

comment:1 Changed 8 years ago by Anton Vodonosov

Component: otherlibraries
Keywords: cffi added
Owner: changed from somebody to Mark Evenson

comment:2 Changed 8 years ago by Anton Vodonosov

Version: 1.1.0-dev

comment:3 Changed 8 years ago by Mark Evenson

Milestone: 1.1.0
Priority: majorcritical
Status: newaccepted

Work around: use the interactive restart provided.

Real solution: create a hash scheme that doesn't change for the same interface.

comment:4 Changed 8 years ago by Mark Evenson

Resolution: fixed
Status: acceptedclosed

Duplicate of #235.

Note: See TracTickets for help on using tickets.