Opened 8 years ago

Closed 8 years ago

#252 closed defect (fixed)

MOP rework broke profiler?

Reported by: Christoph Egger Owned by: ehuelsmann
Priority: major Milestone: 1.1.0
Component: (A)MOP Version: 1.1.0-dev
Keywords: Cc: siccegge@…
Parent Tickets:

Description

Missing slot FUNCTION
   [Condition of type ERROR]

Restarts:
 0: [RETRY] Retry SLIME REPL evaluation request.
 1: [*ABORT] Return to SLIME's top level.
 2: [ABORT] Abort thread.

Backtrace:
  0: (#<FUNCTION {1F5E14C}> #<ERROR {19A6876}> #<FUNCTION {1F5E14C}>)
  1: (APPLY #<FUNCTION {1F5E14C}> (#<ERROR {19A6876}> #<FUNCTION {1F5E14C}>))
  2: (SYSTEM::RUN-HOOK SYSTEM::*INVOKE-DEBUGGER-HOOK* #<ERROR {19A6876}> #<FUNCTION {1F5E14C}>)
  3: (INVOKE-DEBUGGER #<ERROR {19A6876}>)
  4: org.armedbear.lisp.Lisp.error(Lisp.java:382)
  5: org.armedbear.lisp.StandardObject.getInstanceSlotValue(StandardObject.java:307)
  6: org.armedbear.lisp.Profiler$1.execute(Profiler.java:86)
  7: org.armedbear.lisp.Symbol.execute(Symbol.java:813)
  8: org.armedbear.lisp.LispThread.execute(LispThread.java:653)
  9: org.armedbear.lisp.profiler_29.execute(profiler.lisp:165)
 10: org.armedbear.lisp.CompiledClosure.execute(CompiledClosure.java:89)
 11: org.armedbear.lisp.LispThread.execute(LispThread.java:628)
 12: org.armedbear.lisp.Lisp.evalCall(Lisp.java:547)
 13: org.armedbear.lisp.Lisp.eval(Lisp.java:518)
 14: org.armedbear.lisp.Primitives$pf__eval.execute(Primitives.java:345)
 15: (PROFILER:%START-PROFILER :TIME 1)
 16: (PROFILER::START-PROFILER)
 17: (SYSTEM::%EVAL (PROFILER::START-PROFILER))
 18: (EVAL (PROFILER::START-PROFILER))

I was referred to this being due to MOP rework on IRC #abcl

Change History (2)

comment:1 Changed 8 years ago by Christoph Egger

Cc: siccegge@… added

comment:2 Changed 8 years ago by Mark Evenson

Milestone: 1.1.0
Resolution: fixed
Status: newclosed
Version: 1.1.0-dev

I believe this has been fixed with http://trac.common-lisp.net/armedbear/changeset/14207.

Please reopen with more specifics for reproducing the failure.

Note: See TracTickets for help on using tickets.