Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#266 closed defect (fixed)

PSETF.47 ANSI regression

Reported by: Mark Evenson Owned by: nobody
Priority: blocker Milestone: 1.1.1
Component: java Version: 1.1.0-dev
Keywords: ansi-regression Cc:
Parent Tickets:

Description

According to a bisect caused by http://trac.common-lisp.net/armedbear/changeset/14035, but this looks wrong as r14035 merely adds an additional REQUIRE to format.lisp.

Change History (6)

comment:1 Changed 8 years ago by rschlatte

(setf mask-bit) is undefined until mask-bit is called. Maybe outoloading is to blame?

comment:2 Changed 8 years ago by ehuelsmann

Yes. Autoloading *is* to blame. The reasons are documented in setf.lisp line 61 through 67 and setf.lisp lines 93 through 98:

We used to assume we should resolve the symbol-function's autoloader. However, since DEFSETF and DEFINE-SETF-EXPANDER forms aren't required to be in the same file as the actual function, this doesn't work in the general case. Also: resolving every function for which a SETF form is encountered is undesirable because it can/will cause internal functions to be resolved before they're actually required. (This is the old strategy, btw, which caused circular dependencies in autoloaded code.)

comment:3 Changed 8 years ago by Mark Evenson

Milestone: 1.1.01.2.0

comment:4 Changed 8 years ago by Mark Evenson

Resolution: fixed
Status: newclosed

(In [14369]) Implementation of autoloader for SETF generalized references.

Fixes #296. Fixes #266. Fixes #228.

For forms which set the symbol properties of SETF-EXPANDER or
SETF-FUNCTION to function definitions, places stub of type
AutoloadGeneralizedReference? to be resolved when first invoked.

comment:5 Changed 8 years ago by Mark Evenson

(In [14378]) Backport r14369 | mevenson | 2013-02-13 20:01:20 +0100 (Wed, 13 Feb 2013) | 7 lines

Implementation of autoloader for SETF generalized references.

Fixes #296. Fixes #266. Fixes #228.

For forms which set the symbol properties of SETF-EXPANDER or
SETF-FUNCTION to function definitions, places stub of type
AutoloadGeneralizedReference? to be resolved when first invoked.

Does NOT include changes to asdf.

comment:6 Changed 8 years ago by Mark Evenson

Milestone: 1.2.01.1.1
Note: See TracTickets for help on using tickets.