Opened 12 years ago

Closed 12 years ago

#42 closed defect (fixed)

TRACE of FORMAT blows up the stack

Reported by: Mark Evenson Owned by: somebody
Priority: major Milestone: 0.13
Component: other Version: 1.0
Keywords: Cc:
Parent Tickets:

Description

(trace format)
(format t "sfsdf")

will result in a STORAGE-CONDITION

Debugger invoked on condition of type STORAGE-CONDITION:
java.lang.StackOverflowError
	at org.armedbear.lisp.Symbol.symbolValue(Symbol.java:300)
	at org.armedbear.lisp.Readtable.<init>(Readtable.java:123)
	at org.armedbear.lisp.Readtable$2.execute(Readtable.java:348)
	at org.armedbear.lisp.Symbol.execute(Symbol.java:733)
	at org.armedbear.lisp.LispThread.execute(LispThread.java:618)
	at org.armedbear.lisp.with_standard_io_syntax_1.execute(with-standard-io-syntax.lisp:35)
	at org.armedbear.lisp.Symbol.execute(Symbol.java:733)
	at org.armedbear.lisp.LispThread.execute(LispThread.java:618)
	at org.armedbear.lisp.trace_30._execute(trace.lisp:88)
	at org.armedbear.lisp.ClosureTemplateFunction._execute(ClosureTemplateFunction.java:208)
	at org.armedbear.lisp.ClosureTemplateFunction.execute(ClosureTemplateFunction.java:100)
	at org.armedbear.lisp.CompiledClosure.execute(CompiledClosure.java:86)
	at org.armedbear.lisp.Symbol.execute(Symbol.java:777)
	at org.armedbear.lisp.LispThread.execute(LispThread.java:690)
	at org.armedbear.lisp.trace_31._execute(trace.lisp:88)
	at org.armedbear.lisp.ClosureTemplateFunction.execute(ClosureTemplateFunction.java:71)

Change History (1)

comment:1 Changed 12 years ago by ehuelsmann

Milestone: unscheduled0.13
Resolution: fixed
Status: newclosed

Fixed, along with tracing the compiler (which is the cause of this issue), in r11627 and r11628.

Note: See TracTickets for help on using tickets.