Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#152 closed defect (fixed)

ql:closer-mop doesn't work

Reported by: Mark Evenson Owned by: Evenson Not Org
Priority: major Milestone: 1.2.0
Component: CLOS Version: 1.1.0
Keywords: clos quicklisp mop Cc:
Parent Tickets:

Description

CLOSER-MOP fails to load via QuickLisp.

As part of resolving this ticket, it would be nice to produce a summary of what is incomplete in ABCL wrt. MOP.

Attachments (1)

mop-issues.lisp (2.6 KB) - added by Mark Evenson 10 years ago.
Code for problems with MOP

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by Mark Evenson

Actually, CLOSER-MOP loads but fails to work correctly with say CL-TWITTER.

comment:2 Changed 10 years ago by Mark Evenson

Via #abcl

22:35 <loke> Isn't DIRECT-SLOT-DEFINITION-CLASS and
             EFFECIVE-SLOT-DEFINITION-CLASS supposed to be external
             to the MOP package?

Changed 10 years ago by Mark Evenson

Attachment: mop-issues.lisp added

Code for problems with MOP

comment:3 Changed 10 years ago by Mark Evenson

Owner: changed from somebody to Mark Evenson
Status: newassigned

Issues 1, 2, and 3 in the attached Lisp should be solved with r13377.

comment:4 Changed 10 years ago by Mark Evenson

Version: 1.00.24

comment:5 Changed 10 years ago by Mark Evenson

Milestone: 0.260.27

Need to work through MOP issues is duplicate of #5

comment:6 Changed 10 years ago by Mark Evenson

Milestone: 0.270.28

comment:7 Changed 10 years ago by ehuelsmann

Milestone: 0.281.0

This effort seems more like 2.0 to me: after CLHS compliance, we can start working on AMOP compliance. Changing milestone to 1.0 for now -- as there's no active 2.0 milestone yet.

comment:8 Changed 10 years ago by Mark Evenson

Milestone: 1.0unscheduled

wontfix for 1.0

comment:9 Changed 9 years ago by rschlatte

Owner: changed from Mark Evenson to rschlatte

comment:10 Changed 9 years ago by rschlatte

Now abcl svn passes the AMOP test suite, it's just a matter of getting a patch accepted in closer-mop after our next release.

comment:11 Changed 9 years ago by rschlatte

Version: 0.241.1.0-dev

comment:12 Changed 9 years ago by Mark Evenson

Milestone: unscheduled1.2.0

comment:13 Changed 9 years ago by ehuelsmann

Milestone: 1.2.01.1.1

comment:14 Changed 9 years ago by Mark Evenson

Milestone: 1.1.11.2.0
Version: 1.1.0-dev1.1.0

comment:15 Changed 9 years ago by Evenson Not Org

Milestone: 1.2.01.1.1
Owner: changed from rschlatte to Evenson Not Org
Status: assignedaccepted

comment:16 Changed 9 years ago by Mark Evenson

Milestone: 1.1.11.2.0

With abcl-1.1.1 all outstanding reported bugs for integration with closer-mop have been addressed.

comment:17 Changed 8 years ago by Evenson Not Org

Resolution: fixed
Status: acceptedclosed

comment:18 Changed 8 years ago by Evenson Not Org

Works as of [Quicklisp/2013-04-20].

Note: See TracTickets for help on using tickets.