Opened 8 years ago

Closed 8 years ago

#285 closed defect (duplicate)

(setf documentation) is undefined until documentation is called

Reported by: rschlatte Owned by:
Priority: minor Milestone:
Component: interpreter Version:
Keywords: Cc:
Parent Tickets:

Description

Reported by Eric Marsden:

Armed Bear Common Lisp 1.2.0-dev-svn-14349
Java 1.6.0_18 Sun Microsystems Inc.
OpenJDK 64-Bit Server VM
Low-level initialization completed in 0.241 seconds.
Startup completed in 1.128 seconds.
Type ":help" for a list of available commands.
CL-USER(1): (defun foo (x) x)
FOO
CL-USER(2): (setf (documentation 'foo 'function) "Horx")
#<THREAD "interpreter" {482982BF}>: Debugger invoked on condition of type UNDEFINED-FUNCTION
  The function (SETF DOCUMENTATION) is undefined.

Change History (3)

comment:1 Changed 8 years ago by rschlatte

Reproducible for me if I start abcl with -noinit.

comment:2 Changed 8 years ago by rschlatte

Owner: ehuelsmann deleted
Status: newassigned

comment:3 Changed 8 years ago by rschlatte

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #266

Note: See TracTickets for help on using tickets.